Perbaiki: .NET Framework 4.7 tidak didukung pada sistem operasi ini

Menyarankan: Klik Di Sini Untuk Memperbaiki Kesalahan Windows Dan Kinerja Sistem Mengoptimalkan

.Net Framework adalah infrastruktur pemrograman yang diperkenalkan oleh Microsoft. Anda memerlukan .Net Framework untuk menjalankan berbagai aplikasi dan layanan yang berbeda. Sebagian besar aplikasi yang membutuhkan .Net Framework dilengkapi dengan file instalasinya juga. Jadi, secara otomatis akan diinstal pada sistem Anda ketika menginstal aplikasi. Tapi, Anda mungkin melihat kesalahan ".NET Framework 4.7 tidak didukung pada sistem operasi ini" saat menginstal aplikasi. Kesalahan ini akan mencegah Anda berhasil menginstal aplikasi. Anda mungkin melihat kesalahan ini ketika mencoba menginstal .Net Framework sebagai aplikasi / layanan mandiri.

Alasan mengapa kesalahan ini terjadi adalah sama dengan yang disebutkan pada pesan kesalahan. Meskipun .Net Framework didukung pada Windows 10 tetapi tidak kompatibel dengan semua versi Windows 10. Jadi, jika Anda melihat pesan ini maka kemungkinan penyebab kesalahan ini adalah bahwa Anda menjalankan versi Windows 10 yang tidak kompatibel dengan .Net Framework.

Metode 1: Perbarui Windows 10

Satu-satunya solusi untuk masalah ini adalah dengan hanya memperbarui Windows 10. Anda disarankan untuk memeriksa Pembaruan Windows bahkan jika Anda berada di versi terbaru Windows 10. Karena masalah ini disebabkan oleh sistem operasi yang tidak kompatibel, instal semua Windows 10 yang tersedia pembaruan kemungkinan besar akan menyelesaikan masalah. Anda juga dapat memeriksa versi persis Windows 10 Anda dan versi yang dibutuhkan oleh .Net Framework dengan mengikuti langkah-langkah yang diberikan di bawah ini.

  1. Tahan tombol Windows dan tekan R
  2. Ketik winver dan tekan Enter

  1. Versi Anda harus disebutkan di jendela yang baru dibuka. Nomor setelah Versi (di baris kedua) adalah nomor versi Anda. Jumlahnya harus 1507 atau 1709. 2 digit pertama adalah tahun dan 2 digit kedua mewakili bulan. Jadi, jika Anda memiliki versi 1709 maka itu berarti Anda menjalankan versi yang dirilis pada September 2017

  1. Sekarang Anda perlu memastikan bahwa Anda memiliki versi Windows 10 yang kompatibel dengan .Net Framework. Klik di sini dan klik Persyaratan Sistem

Jika Anda melihat bagian Sistem Operasi yang Didukung, dikatakan Pembaruan Ulang Tahun Windows 10 dan Pembaruan Windows 10 Creator . Karena banyak orang yang tidak mengenal nomor versi yang terkait dengan pembaruan Hari Peringatan dan Pembuat, kami telah menyebutkannya di bawah ini

  • Pembaruan November (1511)
  • Pembaruan Hari Jadi (14393)
  • Pembaruan Pembuat (1703)
  • Fall Creators Update (1709)
  • Pembaruan Pembuat Musim Semi (1803)

Seperti yang Anda lihat, Pembaruan Ulang Tahun memiliki nomor versi 14393 dan Pembaruan Pembuat memiliki versi 1703. Jadi, jika Anda memiliki versi yang lebih rendah dari 14393 maka Anda tidak akan dapat menginstal .Net Framework 4.7 pada Windows 10. Sekarang cukup perbarui Windows dan pastikan Anda memiliki versi Windows 10 terbaru dan coba lagi.

Artikel Menarik